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Chapter 1 - About this guide

1 About this guide

1.1 Read me first

Please read this guide carefully before using the device to ensure safe and proper use. Softing does
not assume any liability for damages due to improper installation or operation of this product.

This document is not warranted to be error-free. The information contained in this document is
subject to change without prior notice. To obtain the most current version of this guide, visit the
download center on our website at: http://industrial.softing.com/en/downloads

1.2 Target audience

This guide is intended for experienced operation personnel and network specialists responsible for
configuring and maintaining field devices in process automation networks. Any person using a
pnGate PA EX must have read and fully understood the safety requirements and working instructions
in this guide.

13 Typographic conventions

The following conventions are used throughout Softing customer documentation:

Keys, buttons, menu items, commands and other Open Start > Control Panel > Programs
elements involving user interaction are setin bold
font and menu sequences are separated by an

arrow

Buttons from the user interface are enclosed in Press [Start] to start the application

brackets and set to bold typeface

Coding samples, file extracts and screen output is MaxDlsapAddressSupported=23

setin Courier font type

File names and directories are written in italic Device description files are located in C:
\<Application
name>\delivery\software\Device Description
files

WARNING

WARNING indicates a hazardous situation which, if not avoided, may result in serious
injury or death.

CAUTION
CAUTION indicates a potentially hazardous situation which, if not avoided, may resultin
minor or moderate injury.

Note
This symbol is used to call attention to notable information that should be followed
duringinstallation, use, or servicing of this device.

—

Hint
&/‘ This symbol is used when providing you with helpful user hints.

Video
Dieses Symbol weillt auf ein Video zum entsprechenden Thema hin.

Version EN-062022-1.00 5
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1.5

1.6

Document history

Document version

Changes since last version

1.00

First version

Related documentation and videos

The following links provide additional product information:

" Documents

= Videos

Document feedback

We would like to encourage you to provide feedback and comments to help us improve the
documentation. You can write your comments and suggestions to the PDF file using the editing tool
in Adobe Reader and email your feedback to support.automation@softing.com.

If you prefer to write your feedback directly as an email, please include the following information

with your comments:

= document name

=  document version (as shown on cover page)

=  page number
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Chapter 2 - About pnGate PA EX

2 About pnGate PA EX

The pnGate PA EX is a 2-channel gateway integrating PROFIBUS PA (Process Automation) segments in
PROFINET systems at a fixed speed of 31.2 kbit/s, typically used in areas of process automation with
explosive atmosphere.

Engineering systems and asset management systems
The gateway can be managed with the following tools:

=  PROFINET engineering systems (e.g. Siemens TIA Portal)
=  FDT frame application (e.g. PACTware)

=  Siemens SIMATIC PDM (Process Device Manager)

2.1 Intended use

This series of gateways has been designed to integrate PROFIBUS devices into PROFINET-based
networks. Any other use is not intended. Follow the instructions in this document on how to
configure and operate the gateways.

fﬁ CAUTION
Do not use this device in hazardous areas! See Section SpecificationsD8 for permissible
ambient conditions.

2.2 System requirements

These gateways require the use of a PROFINET engineering system such as the Siemens TIA portal
(version 15 or higher) and STEP 7 (version 5.5 SP 4 or higher). Engineering systems from other PLC
vendors can also be used, provided they support PROFINET GSDML files. Further requirements
include:

. 24V power supply

. one power conditioner per PROFIBUS PA segment
=  PCwith web browser

. GSD file for each PROFIBUS device on your network

=  Javascript must be activated

2.3 Supported features

The pnGate PA EX maps PROFIBUS devices to PROFINET networks. All gateways support the
conversion of PROFIBUS GSD files into a single PROFINET GSDML using an integrated web-based
conversion tool. Other supported features include:

=  Simple connection to PROFIBUS PA devices using PROFINET controllers
=  Integrationin FDT frame applications
= Integration in Siemens SIMATIC PDM

=  Configuration of the gateway in a web browser

Version EN-062022-1.00 7
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n Integrated configurator to start up the PROFIBUS devices

=  Detailed display of the operation state by LEDs

=  Two Ethernetinterfaces (switched internally)

=  Power supply by connectors or rail connectors

24 Specifications
Power supply 18 VDC...32 VDC; SELV/PELV supply mandatory
Typical input current is 200 mA; maximum is 1 A
(considering the rush-in current at switch-on).
Ethernet IEEE 802.3 100BASE-TX/10BASE-T
Minimum ambient operating temperature -40°C (see section Installation positions2™ for
the maximum ambient temperature depending
on the mounting position)
Storage temperature -40°C...+85°C
Relative humidity 10%...95 % (non-condensing)
Altitude Must not exceed 2,000 m
Location Indoor use only; no direct sunlight
Safety standard IEC/EN/UL 61010-1 Safety requirements for
electrical equipment for measurement, control
and laboratory use - Part 1: General requirements
and IEC/EN/UL 61010-2-201 Safety requirements
for electrical equipment for measurement,
control and laboratory use - Part 2-201: Particular
requirements for control equipment (both with
CB scheme).
2.5 Safety precautions
The pnGate PA EX is an electrical equipment with degree of protection Ex ec, approved for use in
Zone 2 hazardous areas or in the safe area.
The pnGate PA EX is only approved for intended and appropriate use. In case of noncompliance, the
warranty and manufacturer’s liability do no longer apply!
if CAUTION
During operation, the device's surface will be heated up. Avoid direct contact. When
servicing, turn off the power supply and wait until surface has cooled down.
Do not open the housing of the pnGate PA EX. It does not contain any parts that need to
be maintained or repaired. In the event of a fault or defect, remove the device and
return it to the vendor. Opening the device will void the warranty!
8 Version EN-062022-1.00



Chapter 3 - Installation

3 Installation

3.1 Hardware installation

With an ambient temperature above 55 °C at the place of installation connecting cables
may heat up strongly if they are installed in an unfavourable position. In such cases,
ensure that the permissible service temperature of the cables (i.e. 80 °C) is not
exceeded or use cables sustaining high temperatures of at least 90 °C.

3.1.1 Installation in hazardous locations

The pnGate PA EX may be used in hazardous locations and is certified according to ATEX.

WARNING

Use only according to operating conditions from instructions! Use the pnGate PA EX in
accordance with its designated use only! Otherwise, the manufacturer’s liability and
warranty will expire. The device is only to be used according to the operating
conditions described in these instructions.

WARNING

Do not connect or disconnect energized conductors! Be aware that energized
conductors are not to be connected or disconnected! This can lead to danger of life if
potentially explosive atmosphere is present there at that time!

3.1.1.1 General requirements

Following general requirements must be observed when installing the pnGate PA EX in hazardous
locations:

=  The details of this document must be observed along with the conditions for use and the
applicable details stated on the marking and type labels of each.

=  Any selection and operation of the device must be done as per the technical rules.

= Adequate precautions must be taken to prevent unintended actuation or impairment of the
device.

= Connectors must not be connected or disconnected when area is known to be hazardous. This
can be life threatening in a potentially explosive atmosphere. Open or not securely closed
sockets shall not be energized in the Ex-atmosphere!

=  Ensure the installed equipment comply with the types of protection applicable to the
corresponding zones.

= All connected electrical equipment must be suitable for the respective intended use.

=  The operator must ensure protection against lightning in compliance with the locally applicable
regulations.

=  Electrostatic aspects must be considered when mounting the bus-modules. Electrostatic charges
have to be prevented.

Version EN-062022-1.00 9
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= |nexplosion group IIC and Zone 2 no protected plastic surfaces > 20 cm? are allowed; in IIB or
dust-Ex, 100 cm? may be reached.

=  The hazard of any objects falling onto the bus-module must be prevented.

= The pnGate PA EX does not meet the requirements of impact protection and IP54 (according to
IEC 60529). It must be installed in a protective enclosure which meets the requirements for
resistance to impact and IP as stated in section 26.4 of IEC/EN 60079-0. This enclosure must be
fully mounted and intact. If the enclosure is damaged, the operation is not permitted.

= Transient protection must be provided at a level not exceeding 140% of the peak rated voltage
value at the supply terminals to the equipment.

=  Whenremoving the packaging ensure that no dirt can enter the enclosure or the plugs.

= |f any vibration during the operation may cause parts of the plugs to loosen, then the plugs have
to be provided with a light firm varnish used for securing screws. An extraction force of 0.5 Nm
has to be achieved at an equivalent thread.

=  Tocircuits of Zone 2 only such equipment may be connected that is suitable for operation in this
zone and has been certified accordingly.

=  Components may only be replaced by original spare parts which are also approved for the use in
Ex-atmospheres. Spare parts are ordered as complete units giving the material number stated
on the device (marking, type label).

=  Only such auxiliary components may be used in potentially explosive atmospheres which meet
all requirements of European and national directives and legislation.

= The environmental conditions specified in the manual have to be followed strictly.

=  The pnGate PA EX is not to be used in systems where cathodic systems for corrosion protection
are in place. Although special precautions may allow the use in such systems (additional
earthing bridges), the manufacturer has to be consulted in each case.

=  The operator has to provide measures for protection against lightning.

=  According to the local conditions and in compliance with the environmental rules, the operator
is responsible to visually inspect the system and to remove dust settlements in a regularly
interval (every 6 months).

=  The company installing the device has to ensure that the transient characteristicis limited to
40% above the service voltage.

= Additional precautions have to be taken, if the presence of hydrosulfide, ethylene oxide and/or
carbon monoxide is to be expected: those substances are of a vary low ignition energy.

= [cingis not permitted.

10 Version EN-062022-1.00
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CAUTION

Make sure that the sum of power supply voltage and fieldbus supply voltage does not
exceed 60 VDC!

>

f: Explosion hazard
Do not disconnect equipment unless power has been removed or the area is known to
be non-hazardous.

Observe relevant national regulations, standards and directives
This manual does not supersede the relevant national regulations, standards and
directives. These must be observed and have to be applied according to the national
conditions!

3.1.1.2 Hazardous Location - European and International Approval (ATEX)

The equipment has been assessed based on the following standards and editions:
= EN IEC 60079-0:2018
= EN IEC 60079-7:2015+A1:2018

If indicated on the device label or by technical documentation, the pnGate PA EX is suitable for use
in gas-Ex atmospheres of Zone 2in the explosion groups lIA, IIB and IIC in temperature class T4, if
accommodated in a tested enclosure.

The pnGate PA EX complies with the applicable standards and regulations and meets the
requirements of Directive 2014/35/EU. The requirements for erecting the device as part of the
system in potentially explosive atmospheres (e.g. IEC/ EN 60079-14) must be strictly adhered.

Version EN-062022-1.00 11
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3.1.2 Mounting and dismounting

Note

Make sure the pnGate PA EX is mounted in such a way that the power supply can be easily
disconnected.

Depending on the installation position, the maximum ambient operating temperature
may differ. See Section Installation positions DB for details.

fi Installation and inspection
Installation and inspection must be carried out by qualified personnel only (personnel
gualified according to the German standard TRBS 1203 - Technical Regulations for
Operational Safety). The definition of terms can be found in IEC 60079-17.

Mounting

1. Hook the upper notch of the cut-out on the back of the
pnGate PA EX into a 35 mm DIN rail. =

2. Pressthe device down towards the rail until it slides \)
into place over the lip of the locking bar. 1 E' e

Note
Do not put stress on the system by bending or

torsion.

Dismounting

1. Slide ascrewdriver diagonally under the housing into
the locking bar.

2. Leverthe screwdriver upwards, pull the locking bar
downwards - without tilting the screwdriver - and
move the gateway upwards off the rail. : 1

12 Version EN-062022-1.00



Chapter 3 - Installation

3.1.3 Connection diagram

The following diagram shows the input and output interfaces of the pnGate PA EX with its 2 physical
PROFIBUS segment connections (PAOto PA1).

Power Supply Redundancy

24V DC Link (RDL)
GND L L+ GND TX RX
123 456
! D
i=C )
Rail
Power J ETH1
Supply GND
24V DC L+ ]
PA1 PAO
\ J ETH2

121110 9 8 7 Fieldbus
-8+ -8+

£ £

3.1.4 Connecting the power supply

Connect the gateway to a 24V DC power supply (not included in the delivery).The supply voltage (18
VDC .... 32VDC) is connected by a 3-pole terminal block. The power supply is connected to the plug
connector via flexible wires with a cross section of 0.75 to 1.5 mm?2. The ground connection wire must
have a cross section of 1.5 mm?2.

H_n Pin Signal Description
1 GND Ground
@@@ 2 JT; Functional earth
3 2 1 3 L+ Positive supply voltage

CAUTION
& The Functional Earth (FE) connection of the device has to be connected at low inductance
with the Protective Earth (PE) of the system.

Note
As the connection diagrams show, the power can also be applied by a special DIN rail

connector (Rail Power Supply). For further information contact Softing Industrial
Automation GmbH.

Note
See also the maximum ambient temperatures in the Section Installation positionsD™ .

Version EN-062022-1.00 13
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3.1.5 Connecting to the network

1. Connect each segment of your PROFIBUS network to a port of your gateway. Be sure that each
segment is powered by a power conditioner. If you connect to field devices in explosive
atmospheres ensure that you also connect a field barrierin between.

2. Connectthe gateway from one of the two Ethernet ports with your PROFINET network.

3. Connectyour PCrunning the engineering and asset management tools using the second
Ethernet port.

pnGate PA EX network topology

Plant Asset Management ENGINEERING
e Modbus OPC S
Application ocbus erver ComConf / web browser

Ethernet
Modbus TCP
PAC PLC RTU I T I SWITCH

Device Device Device

Power
Conditioner

@ FouNDATION fieldbus H1

Field Device Field Device Field Device

14 Version EN-062022-1.00



Chapter 3 - Installation

3.1.6 Installation positions

pnGate PA EX can be mounted horizontally and vertically. Depending on the installation position,
different ambient operating temperatures (T,) are allowed.

convection.

Rotated installation position

Minimum distance
Provide a minimum distance of 50 mm to the airinlet and air outlet to ensure natural

The maximum permissible ambient temperature values also apply to a 180° rotated
installation position.

Horizontal installation position and maximum temperatures

Number of PA Max PA fieldbus voltage | Min distance Max ambient temperature
channels T,

0-2 24VDC 0mm 55°C

0-2 24VDC 17.5mm 60 °C

Vertical installation position and maximum temperatures

1|

.

T T T ]

00 oo [loo oo oo oo

oo%
060 ©0O0
&
| =t

00%
00 o©O°0
dd
=

Number of PA Max PA fieldbus voltage | Min distance Max ambient temperature T,
channels

0-2 24VDC 0Omm 45°C

0-2 24VDC 17.5mm 55°C
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3.1.7 Powering up the device

Turn on the power supply. The boot process will take around 15 seconds. For indication of proper
operation refer to LED status indicators0* .

16 Version EN-062022-1.00
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3.2 Software installation

When you install a Softing product for the first time, you will be asked if you trust the
publisher. Activate the option Always trust software from Softing AG if you do not want to
be asked in subsequent installations and select [Install] to start the installation.

1. Go to the Softing Industrial Products - Gateways > Gateways for multi-protocol process control
and download the latest product software.

2. Start by downloading and installing the Search and Configure tool.
3. Follow the on-screen installation instructions.

4, Readthe license agreement carefully.
If you have questions, you can [Cancel] the installation at this point and contact us. Click [Print]
if you want to print the license agreement to a PDF or on a printer.

5. Select | accept the terms in the license agreement and click [Next].

6. Click [Install] to install the selected software application on your PC.
While the installation is in progress, the status bar of the installation wizard shows the different
steps that are being executed. If you want to abort the installation, click [Cancel] button. The
installation wizard will undo all modifications that have been made to your computer up to this
point. Otherwise, wait until the installation is completed.

7. Press [Finish] to complete the installation and exit the wizard.

Note
Proceed with the installation of the other software packages.

Additional installations
Depending on your use case, install one of the following software packages:

= |nstall an FDT frame application if you are using FDT technology.

= |nstall PROFIdtm separately if you are not using PACTware but another FDT frame application
like FieldCare or FieldMate.

= Install PDM libraries for integration into Siemens PDM.

Version EN-062022-1.00 17
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4 Configuration
The pnGate PA EX connects to an integrated web server to configure the gateway and the connected
PROFIBUS devices. One of the functions of the web serveris to convert PROFIBUS GSD files into a
single PROFINET GSDMIL file. The configuration is typically done offline in the PROFINET engineering
system (e.g. Siemens TIA Portal) meaning that you do not need to be connected to a controllerora
gateway.
The default IP address of the integrated web serveris 192.168.0.10. To access the pnGate PA EX from
your PC, you either have to change the default IP address of the integrated web server to an address
on your network or change the DHCP address on your PC to a static IP address that matches the
network address of your gateway (e.g. 192.168.0.1). The following Chapter describes how you have
to do one of the two options.

4.1 Prerequisites
= Ensure that you have downloaded and installed the latest firmware.
=  The pnGate PA EX is connected to the PROFIBUS PA segment.
=  The pnGate PA EX is connected with a PC which runs a standard Internet browser supporting

JavaScript.
=  The Search and Configure tool is installed.
. GSD files (electronic device descriptions) corresponding to the PROFIBUS devices are available
on the PC.

=  The PROFINET devices are connected to the PROFINET PA segment.
pnGate PA EX requires the following communication ports to be available:
Application m Port Type
Web Interface 80/443 TCP
Search and configure 1900, 2355, 5353 UDP/Multicast
PDM, DTM 2357 TCP
Modbus Communication 502 (default) TCP

18
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Chapter 4 - Configuration

4.2 Changing the IP address of the pnGate PA EX

Before you can configure the connected pnGate PA EX you will have to change the preset IP default

address of your gateway so that the integrated web server can communicate with your PC over the
Local Area Network.

Searching for devices
The following steps apply to Windows 10.

1. Click Start > Softing > Search and Configure.
The application window is opened.

-
@ Search and Configure = [
Connected devices in local network:
MAC Address Device Type _Serial Number Name 1P Address TP Mask Gateway
Metwork Adapter Selection: Office : 172.17.1.218 -
Search Configure Configure via CSV file About Close

2. Openthe Network Adapter Selection.

3. Select the network on which you want to search for the connected gateway.
This selection menu shows all networks you can access from your PC.

4. Click [Search] to start searching for connected devices.
The search may take some time. The window Connected devices in local network appears.

@ search and Configure — [m] *

Connected devices in local network:

MAC Address Device Type  Serial Number IP Address IP Mask Gateway

§] 00-D6-71-2f-D4-aa pnGate PA 145100199 pnGatePA _ 255.255.0.0 0.0.00

Netwark Adapter Selection: Ethernet 5 : 192.1658.0.1 -

Search Configure Configure via CSV file About Close

5. Select the network device you want to configure.

6. Click [Configure] or double-click the device.
The configuration window opens. Here you can modify all relevant values.

@ Configuration of pnGatePA (pnGate PA) ? x

New Values Current Settings
Host name prGatePA pnGatePA

1P address |192,168.0 . 10]
Subnet mask 255.255.0 .0

Default gateway address 0.0.0.0

Maintenance IP address 0.0.0.0

Use DHCP v

Fi version 10

HW version 100

User name administrator

Password ensane

Submit Cancel

Version EN-062022-1.00 19
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7.

8.

Note
If you are starting the connected pnGate PA EX for the first time and you have not
yet assigned user roles for the gateway, the user name in the configuration window

is preset to administrator.
Enter the default password FGadmin!1 for username administrator.

Click [Submit].
The changed settings are written to the device.

Note

For the PROFINET communication to work properly ensure that the device's web
server does not use the same IP address that is used by the PROFINET engineering
system (e.g. TIA Portal) for the gateway.

20
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4.3 Setting the IP address of the PC

If you have not changed the IP address of a pnGate PA EX as described in the previous SectionP™ you
will need to configure the IP address of your PC to access the gateway from your PC.

The following chapter describes how to set a static IP address in Windows 10.
1. Click Start > Windows System - Control Panel from your task bar.

2. Select Network and Internet > Network and Sharing Center.
A new window opens where you can view your basic network information.

3. Click onyourInternet connection (either Ethernet or wireless) next to Connections under View
your active networks.
A new window opens.

4. Click [Properties].

5. Select Internet Protocol Version 4 (TCP/IPv4).
The following window opens.

Internet Protocol Version 4 (TCP/TPw) Properties L‘g_ﬁ

General

You can get IP settings assgned automatically if your network supports
this capability. Otherwise, you need to ask your network administrator
for the appropriate [P settings.

Obtain an IP address automatcally
l @ Usge the folowing IP address:l

IP address: 192 . 168 . 0 .1
Subnet mask: 255,255 .255. 0
Default gateway:

i@ Lise the following DINS server addresses:
Preferred DNS server:

Alternate DNS server:

Validate settings upon exit I Advanced... B

6. Select Use the following IP address and enter a specific IP address and Subnet mask. In our
example we use the following settings:
IP-Adresse: 192.168.0.1
Subnet mask: 255.255.255.0

7. Click [OK] to confirm.
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4.4 Login to user interface
1. OpenyourlInternet browser and enter the IP address of your gateway.
Note
If you don't recall the IP address of your gateway, start the tool to find out what it is
(see Step 2 below).
2. Click the IP address of the gateway to launch the login window in your web browser.
@ search and Configure N EI@
Connected devices in local network:
MAC Address Device Type jerial Numbe Name IP Address IP Mask Gateway
1 00-06-71-2d-... FG-200 HS... 141800051 fg-x00-1418000... 1 255.255.0.0 172.17.0.160
2/00-06-71-2d-... FG-200 HS.. 160700161 fg-x00-1607001. 17217113 @ 255.2550.0 0.00.0
3/00-06-71-f-0... mbGate PA.. 172600266 mbgatepal7260.. [17217..158] 25525500 | 172.2013.110
Network Adapter Selection: LAN-Verbindung : 172.17.3.72 -
Search Configure Configure via CSV file About Close
3. Select the administrator symbol and enter FGadmin!1in the password field.
administrator config view
(Administrator) (Maintenance) (Observer)
User Name: |adminislrator ‘
Password: | ‘
Login
The gateway's web-based interface opens with the information page.
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4.5 Changing the password

1. Logontothe web interface of the gateway.

2. Select Settings > User Accounts.
As administrator you can change and confirm the passwords for different roles.

See details below.

administrator config e
(Administrator) (Maintenance) (Observer)
Liser name I
Old password | iy
Mew passward I M
Confirm new password I &

3. Click one of the icons (administrator, config or view) and enter the Old Password and the New
Password in the corresponding fields..

4. Retype the password in the Confirm new password field and click [Apply] to save the modified
password.

Note
Be careful when changing the administrator password! If you lose your changed

administrator password, you can no longer make changes to configurations or settings.
In this case contact Softing support.

Access to your pnGate PA EX configuration tool is managed by user roles where each role has certain
permissions. The following user roles are available:

Role Username Password
Administrator administrator FGadmin!l
Maintenance config FGconfig!l
Observer view FGview!l

Additionally, your pnGate PA EX can be accessed remotely with the user roles Diagnostics (psw: ?
<fJ#\/$eB2qtGd*)and Expert ( psw: FS-OsHnc7BWia { 6w<). Both user roles are reserved strictly for
Softing Support purposes.

Version EN-062022-1.00 23



pnGate PA EX - User Guide

Itis strongly recommended to change the Diagnostics and Expert passwords immediately
by entering the user name in the input field instead of selecting one of the icons above.

The following table shows the permissions/actions of each user role:

Permission Administrator Service Engineer Observer
Setting password |

Configuring gateway | M

Reading configuration 4| M |
Reading diagnostics 4| M |
Updating firmware 4]

Resetting gateway 4|

Installing HTTPS certificates |

24
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4.6 Updating the firmware

The gateway comes with pre-installed firmware which is maintained and updated to continuously
enhance the functionality of the device. To ensure that your pnGate PA EX is always running the
most recent version check the Softing Download Center for the most recent firmware update.

You need to be logged in as administratorD? .

1. Download the firmware update to your computer.
When you are downloading from this site for the first time you will have to register yourselfin a
few steps.

2. lLogontothe web interface of the gateway.

3. Select Settings > Firmware in the side bar navigation.

Firmware Update

Choose Firmware File...

W
Current Firmware: 1.20.00.8095
Firmware File: No file selected.

Firmware Name:
Firmware Signed:
Firmware Encrypted:

4. Click [Choose Firmware File...] to select the firmware file you want to download.

5. Click [Update] to download the firmware file and to reboot the system.
The system performs a firmware file check. The download starts automatically. When the
download is completed the pnGate PA EX will be rebooted. When the boot process is
completed, the RUN LED is ON.

Note

Do not access the web server of the pnGate PA EX before the "Success" message is
displayed in the browser window. Otherwise you will have to clear the cache of your
web browser after the boot process has finished and reconnect to the web server of
the pnGate PA EX.
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4.7 PROFINET configuration in the TIA Portal
The following chapter describes how to convert the GSD file of a PROFIBUS PA field device to a
GSDML using the built-in PROFIBUS configurator and how to use this file to configure a PROFINET
device in the Siemens TIA Portal (Totally Integrated Automation Portal).
m Video
See also the videos Conversion from PROFIBUS GSD to PROFINET GSDML and PROFINET
configuration in the TIA Portal.
4.7.1 Prerequisites
=  You must have installed the Siemens TIA Portal on your PC to optimize the PROFINET
configuration routines.
®=  You must know how to create and manage projects in the TIA Portal.
4.7.2 Creating a GSDML import file
1. Logontothe the userinterface of the gateway with your username and password.
2. Select PROFIBUS > Configuration.
pnGate PA 4xPA Infarmation Settings Diagnosis PROFINET 10 PROFIBUS
Wiews Configuration
Lax Enginzering system:  [TIA Fortal FCS 7, .. 7| Flantname:  [FOM_DTM_Testrack]
Configuration Device Catalog Segment Configuration
Actions g Cerahar M Pa o Segment PAD Segment PAT
EEaT “ersion: Profile 3.0 330 File Mame: EH3X151C.GSD > . T
Remove All GSDs " Cerabar 5, 2nd Generation PA o Acddress: o 2 Device Ty
Clear Configuration S e
Load Configuration >
Deltapilot 5 PA  +
Save Configuration Manufacturer: Endress+Hauser  Idert humier. 01503
e ferzion: Profibus e Mame: __
GSOML g ESKS-PA PA 4
3. Determine for which engineering system and for which installation (plant name) you want to
generate a GSDML import file. The engineering system in the configuration page is set by
default to the TIA Portal.
As each engineering system often only supports a specific GSDML format, it is
recommended that you select the engineering system you are using before converting
the imported GSD files.
4. Click [Import GSD] in the side menu.
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Select the file(s) you want to import in the File Upload window and confirm the upload to the
Device Catalog of your application clicking [Open]. You can add up to 64 files for conversion.The
selected file appears under Device Catalog.

Click [Generic GSDML] in the side menu to generate a single GSDML file from the GSD files in
the Device Catalog. If the GSMDLfile is not automatically saved, save it manually to your PC.

Alternatively, click [GSDML] in the side menu to generate a single GSDML file from the GSD files
used in the Segement configuration.

Note

By selecting [Generic GSDML] you will generate a GSDML file from all the devicesin
the device catalogue. Remember that the PROFIBUS configuration of the segments is
not stored in the GSDML which implies that the assignment of the devices to the
PROFIBUS channels and the parameters of the devices must be done in the PROFINET
engineering system (e.g. TIA portal). If you choose to convert the GSD files to a static
GSDML file using the [GSDML] function the PROFIBUS devices and the used IO
modules cannot be manually altered later in the PROFINET engineering system (e.g.
TIA portal).

4.7.3 Creating a new project in Siemens TIA Portal

Open or create a new project in the TIA Portal using the PROFINET Controller.
Start the TIA Portal.

1

2.

Click [Create new project].

Enter a project name and path.

Click [Create] to create a new project.
The projectis created and will open automatically.

Select Open Project view.

Select Options > Manage general station description files (GSD).

Online |Dption5 |Tcu3|s Window Help

#| Show reference text

w1 1] Global libraries :

Y Semings |e ¥ Goo

Support packages m

Manage general station description files (GSD)

Start Automation License Manager

Navigate to the folder where the generated GSDML (see Creating a GSDML import fileD® )is
stored, tick the check mark of the file and click [Install].

Click [Close].
The Hardware Catalog is updated.
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10.

11.

12.

13.

14.

15.

16.

17.

Double-click [Devices & Networks] to open the Network View.

Open the Hardware Catalog.

Select Other field devices - PROFINET IO > Gateway - Softing Industrial Automation GmbH >

Softing Process Automation Gateways.

Select the project name you entered in Step 3.

Select DAP.

Options

~| catalog

| =earch>

[ Filter
» [ Controllers
» [ Hw
» :!] FC systems
» [ Drives & starters
» [ Network components
» [l Detecting & Monitoring
» [1‘. Distributed IO
» rﬂ Field devices
vr_f. Other field devices
« (1l PROFINETIO
» [l controllers
» [ Drives
» [ Encoders
Vﬁj Gateway
» [l SIEMENS AG

Il oaF
Il oar

- rﬂ Softing Industrial Automation GmbH
] i{. Softing pnGate PA
~ (1l Softing Process Autamation Gateways
~ [ Fieldbus Praxy

DAF (v1.0.0)

[ Jo 1700

=l -

Select Version in the information dialog to identify the correct GSDML by date and time stamp.

Select the gateway, drag it from the Hardware Catalog and drop it into the Network View.

Click [Not assigned] in Network View.

Select the controller.

28
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& Topology view ||h-ﬂ-g, Network view |||]1' Device view |
= JNetmrkoverview 4| »

(] :
= 'ﬁ’ Device
¥ S71500/ET200MF sta..
pnGatePA > » CPUIS1E
Ny ¥ G5Ddevice_1
DAP (v1.10.0} 2hed — P;
Sy 25 nGate
MESr_--Iett 10 controller = P
CPU1516.FPROFINET interface_1

Now the gateway is assigned to the controller

CP1516_pnGatePA » Devices & networks

gx Metwork| $3 Connections |HI- l connection [«] B % HE G‘l :
T
CPU1516 pnGatePA il
CPU 1516-3 PNI_. DAP (V1.10.0}
CFU1516

CPU1516.PROFINET I0-5y___

18. Double-click the gateway icon to open the Device View.

‘; Topology view ||Eg-ﬂ Network view HI]T Device view |_
i J Device overview |
biad 't" Module Rack Slot | address
~ pnGatePA 0 0 =
* Interface 0 0 DAP... ]
Ethernet Port 1 o] 0 DAP...
= Ethernet Port 2 0 0 DAP...
r * Fieldbus Access Points (2 xP.. 4] 1
Fieldbus Access Points (2. i) 11
Fieldbus Access Points (2. 1] 12
4] 2
i 0 3 =
1] 4
o 5
o 6
0 7

19. Dragamodule to afree slot. The supported submodules are shown under Submodules.

20. Click the gray device symbol and select a submodule (e.g. temperature value) from the catalog
to open the corresponding Properties dialog (configure the parameters of the submodule if
required - similar to PA Function Block).
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21.

22.

- r_[. Fieldbus Proxy
Il oAF (v1.10.0)
~ [ Module
4 P_[. Endress + Hauser
» [ Endress+Hauser
u Fieldbus Access Points (1 xPA)
[l Fieldbus Access Points (2 xPA)
u Fieldbus Access Points (2 xPA, 1 xDF)
[l Fieldbus Access Points (4 xPA)
[l Fieldbus Access Points (4 xPA, 1 xDF)
» (il KROHNE Messtechnik GmbH
» ([l Metso Automation
» (i FROFIBUS-FA Frofile
» (i PROFIdrive
] p_[. softing
~ [ VEGA Grieshaber KG
Il vEGAPULS 40i50
Il vEGason 50
[l veGasON 50
» [ wika
Al 1submodules
- ([l VEGAPULS 40/50
Il 21 (FA-OUT, long)
Il ~ (PA-OUT, short)

Options [2[a]

dlF

L. 2
v | catalog =
]

|<Search> ”E@ 2
[ Filter g
~ [1j Head module &

$]003 BUIjUQ E”

syse| @n”

sapeiqr E”

Select Slave Proxy - General - Module parameters and set the PROFIBUS master channel to
the channel to which the PROFIBUS device is connected.

Enter the Slave Address.

If required, you can configure the parameters of a submodule in this dialog window after
selecting it (corresponding to PA Function Block).

Fieldbus Access Points (2. 0 12 |
— ~ VEGAPULS £0/50_1 o 2
L Slave proxy | o 21
p——— 5
W =T . Al (PA-OUT, lang). g §2 0.4
[} 0 a
i 0 5
0 6
0 <
0 8
o 9
0 10
0 1
0 12
E} 0 13 vl
<] o [l ——— & ] e ol
| & Properties  ["}Info @] Diagnostics |
IGenelaI IIO tags H System constants H Texts |

~ General
Module parameters

Catalog information

|dentification & Maintenance

Module parameters

Hardware identifier

Slave Address: [ 1

Slave Channel/Address assignment

PROFIBUS Channel [0.4]: |0

30
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23. Select the default PROFINET IP address settings or click the gateway to configure these settings
in Properties > General.

Note

Do NOT to use the same IP address for the gateway and the device's web server.
Example: 192.168.0.10is the web server's default address. Use a different IP address for
the PROFINET. For information on how to change the web server's address refer to
Changing the IP address of the pnGate PA EXB™

E3 | [3][oox 7] —s— @& <] i | 2] ]
|ielProperties il info 1|2 Diagnostics |
[ General ] 10 tags [ System constants | Texts |
+ General Il [~]
Catslog information Hibe i ’E’]
~ PROFINETinterface [X1] Interface networked with I
General

Ethernet addresses Subnet: | PIUE_7 [+
Identification & Maintenance T
~ Advanced options
Interface options
ly IP protocol
» Real time sewings
{8 (& use 1P protocal
Synchronization b
SetIP addi in th ject
» EthemetPort1[X1PIR] | LR

» Ethernet Port 2 [X1 P2 R] Paddress: [ 192 1680 .2 |
Hardware identifier Subnet mask 255 . 255 . 255 .0 ‘

Identification & Maintenance

Hardware identifier

Shared Device outer address
() 1P address is set directly at the device

24. Save the project and download it to the device.
25. Select the corresponding PC network interface where the controlleris connected.

26. Click [Load] and [Finish] to complete the setup.

Toad preifiéw %
9 Check before loading
Status |1 | Target Message Action
M @ =~ crisis Ready for loading.
(] » Stop modules The modules are stopped for downloading to device. Stopall
] » Software Download software to device Consistent download
/] Text libraries Download all alarm texts and text list texts Consistent download
[<] [ [2]
[ refesh |
| Finish ‘ ! Load i cancel |

A confirmation window appears displaying the message Downloading to device completed
without error.
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4.7.4 Updating and uploading a GSDML file
If you add new PROFIBUS device to a segment in the gateway user interface you will need to update
the GSDML and upload it to the PROFINET engineering tool (TIA portal) using the update feature of
the TIA portal to avoid the loss of I/Q address parameter.
4.7.4.1 Generic GSDML
The following steps describe how to add a new PROFIBUS device and update the generic GSDML (see
also Chapter Generating a GSDML import fileD?).
1. Logontothe the userinterface of the gateway with your username and password.
2. Select PROFIBUS > Configuration.
3. Import the GSD file of the PROFIBUS device to the Device Catalog in the gateway user interface.
4. Click [Generic GSDML] to generate the new GSDML file.
4.7.4.2 GSDML
See also the videos Conversion from PROFIBUS GSD to PROFINET GSDML.
1. Logontothe the userinterface of the gateway with your username and password.
2. Select PROFIBUS > Configuration.
3.  Importthe GSD file of the PROFIBUS device into the Device Catalogin the gateway user
interface.
4. Assign the device to the PROFIBUS segment(s) in the Segment Configuration.
5.  Addthe IO modules.
6. Setthe PROFIBUS address.
7. Click [GSDML] to generate the new GSDML file.
4.7.4.3 Device catalog update in TIA portal
1. Openthe TIA portal project.
2. Select the existing PROFINET gateway device in the Hardware Catalog under Other field devices
> PROFINET 10 > Gateway - Softing Industrial Automation GmbH - Softing Process
Automation Gateways.
3. Import the new GSDML which you can identify by the date and time string in the file name.
4. Selectinthe left side menu Devices > Devices & network.
5. Select the gateway you want to update in the Device view > Devise overview window.
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8.

T4 Siemens - C:\Users\GEN4C\Desktop\TestiTest

Project Edit View Insent Online Options Iook Window Help

G (Y seveproiecr & G X 9t G MG E R Y coonine I cooiine do I8 M % = (1] [Feocnooe |
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Totally Integrated Automation
PORTAL

@ EX
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DGl [ Properties |*uinfo ] & Diagnostics _| 3
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» [ PLC dota types Gatalog information L
» [53 Watch and force tables v PROFINETinterface [X1] 4:1
» [3g Oniine backups Geners! Neme: [pnGatere 3
» [ Traces Ethemetsddreszer Author: [gensc 5
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> ~ Advanced option: AR B o
Interface options E
Media redundancy H]
» [ Local modules » Ethemet ort 1 1 P1 8] L ——
» [ Distributed 10 » Ethemet ort2 X1 P21 sovfo | I
+ IR Ungrouped devices dentifcation & Maintenance
= Catalog information
» (5] Documentation settings
[ose

» [ Language: & resources

» g Online sccezz Description:
» (3 Card Readeriuse memory
[Details view p—

PROFIEUS Fieldbus Proxy

Fimware version: [V1:30.00

Hordware [100

Name Gsofle: [geamiz

200113-152555.ml

4 Portal view

6

Click the [Change revision] button in the Catalog information window.

Select the GSDML file imported in Step 3 (check date and time string) in the new window that

appears.

GSD file - change revision

Available revisions

GSD file Version
gsdmlwv2.34-#softing-pngatepa-20121108-132227 xml v2.34
gsdmlwv2.34-#softing-pngatepa-20121108-134854 xml v2.34
sdml-v2.34-#softing-pngatepa-20200113-152555.xml v2.34

v2.34

gsdmlwv2.34-#softing-pngatepa-20200113-153323 xml

Revisicn

11i8i2019 1:22 PM
11i8/2019 1:48 PM
1/13(2020 3:25 PM
1/13/2020 3:33 PM

X

(<] i

Use selected revision for
@the current 10 device
OHII matching 10 devices of the 10 system
(") All matching 10 devices of the current project
Compatibility information

Informaticn

@ pnGatePB: Change version 'gsdml«v2 34-#softing-pngatepa-20200113-152555.xm|".

oK Il

Cancel

Instantiate the new PA device module and assign the correct parameter to the new device if

you imported a generic GSDML.
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4.7.5 Switching from a 2-channel to a 4-channel gateway

You can switch from a 2-channel to a 4-channel gateway to support more PROFIBUS devices in your
network. To do this it is recommended to use the Change Revision in the TIA portal feature.

4.7.5.1 Generic GSDML

The following steps describe how to switch from a 2-channel to a 4-channel gateway and how to
update the generic GSDML (see previous chapterD® ).

1.

Log on to the the user interface of the gateway with your username and password.
Select PROFIBUS - Configuration.

Import all GSD files of the PROFIBUS devices from the 2-channel gateway into the device catalog
of the 4-channel gateway.

Click [Generic GSDML] to generate the new GSDML file.

4.7.5.2 GSDML

The following steps describe how to switch from a 2-channel to a 4-channel gateway and how to
update the GSDML (see also the video Conversion from PROFIBUS GSD to PROFINET GSDML).

1.

Log on to the the userinterface of the gateway with your username and password.
Select PROFIBUS > Configuration.

Load the existing PROFIBUS configuration project of the 2-channel gateway into the 4-channel
gateway.

Click [GSDML] to generate the new GSDML file.

4.7.5.3 Device catalog update in TIA portal

1.

Open the TIA portal project.

Select the existing PROFINET gateway device in the Hardware Catalog under Other field devices
> PROFINET 10 > Gateway - Softing Industrial Automation GmbH - Softing Process
Automation Gateways.

Import the new GSDML file which you can identify by the date and time string in the file name.

Select in the left side menu Devices > Devices & network.

Select the gateway you want to update in the Device view > Devise overview window.

34
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9.
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Remove the 2-channel FAP module (Fieldbus Access Port) from the selected gateway. The FAP

module is always located in slot 1.

Click the [Change revision] button in the Catalog information window.

Select the GSDML file imported in Step 3 (check date and time string) in the new window that

appears.

GSD file - change revision

Awailable revisions

GSD file Version | Revision

gsdml2 34-#softing-pngatepa-20191108-132227 xml v2.34 111812019 1:22 PM

gsdmlv2.34-#softing-pngatepa-20191108-134854 xml v2.34  11i8/2019 1:48 PM
sdml-v2.34-#softing-pngatepa-20200113-152555.xml v2.34  1/13/2020 3:25 PM

1/13/2020 3:33 PM

gsdmlv2.34-#softing-pngatepa-20200113-153323 xml

<] I

Use selected revision for

(®) the current 10 device
() All matching 10 devices of the 10 system
() All matching |0 devices of the current praject

Com patibility information
Information
@ rpnGatePB: Change version 'gsdml-v2 34-#softing-pngatepa-20200113-152555 xml".

X

Instantiate the new PA device module and assign the correct parameter to the new device if

you imported a generic GSDML.
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4.8 PROFIBUS parameterization with PACTware

The following chapter describes how to configure a PROFIBUS driver and parameterize PROFIBIUS
devices in PACTware using the Device Type Manager PROFIdtm.

a Video

See also the video PROFIBUS parameterization in PACTware.

4.8.1 Prerequisites

=  |f you are working on Windows 7 and you have disabled the automatic update service you must
check if Microsoft hotfix KB3033929 is installed.
Open acommand line, click [Start], type cmd and in the command window that opens, type
wmic gfe|find "3033929".
The answer contains information about the time, date and Internet address of the
installation.The Search and Configure tool is installed as described in the Section Software
installationD" .

=  The default IP address of the built-in web server has been changed to an address on your
network or the DHCP address on your PC has been changed to a static IP address corresponding
to the network address of your gateway (e.g. 192.168.0.1). See chapter Setting the IP address of
the PcD?' .

= An FDT frame application (e.g. PACTware) is installed.

. PROFIdtm is installed.
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4.8.2 Configuring the PROFIBUS driver

1

2.

10.

11.

Select Start > Control Panel.

Click PROFIBUS to configure the PROFIBUS driver.

Allow Windows User Account Control (UAC) to modify settings.
The PROFIBUS Control Panel is opened.

Select a pnGate PA EX.
Click [Add...] and enter a symbolic node name (default value is Node0).

Click [Next] and enter the IP address of the pnGate PA EX in interface name field of the next
window.

Select a bus segment (e.g. PAO) and click [Next].
Currently segment 1 or segment 2 are supported.

Click [Next] and set the timeouts (Timeout for Connect and Max Idle Time).
In most cases you can keep the default settings.

Click [Finish].

Click [Apply] and confirm saving all settings with [Yes].
The device node is shown with a green check mark.

- PROFID45 Firmware Version  PA-Master 546.0010070  s\PRO

i PBpra PC104+ / PBpro PC |
- PBpio PCI / PBpro oFCl :E:’;;'ﬁ‘ess ;gg; B

FBpmo PCle

-PBpioETH /FG seties | Dayice Mames % \PROFIBUS \Board0MBoard v
= po ~ PA

1 2 YW APROFIBUSNBoardWPbOMS ervice
4% APROFIBUSYBoard0WPbOMDpD ata

Alias Dew. Mamez  WWAPROFIBUS\ModeD\Board
Y APROFIBUS\HodelhService
Y% APROFIBUS M odetDpD ata

1
¢ [ T ' T 3
|This device iz working properly i
]
Scan... I (] 4 I Cancel | I Apply I
== ——— = =_a = — .|

Click [OK] to close the PROFIBUS Control Panel.
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4.8.3 Creating a project in PACTware

1. Start PACTware.

Right-click Host PC > Add Device in the device tag column of the project view.

Project

Device tag
1=} HOST R

f= Connect

_--\1:3 Disconnect

Topology Scan

#3  Add device I

A new window appears with the available devices.

3. Select PROFIdtm DPV1 from the list and confirm with [OK].
The device is displayed in the project view.

Note
Before you start a topology scan make sure the corresponding device DTM is
installed.

4. Right-click PROFIdtm and select Topology Scan from the list.
The topology scan window is opened.

5. Click the arrow in the scan window to start the topology scan.

@ 44 Close Settings

PROFIdtm connects to the network and starts the scan. The device detected is displayed
together with its corresponding device information.

PROFIdtm and the PA devices are displayed in the project view.

38
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4.9 PROFIBUS parameterization with SIMATIC PDM

The following chapter describes how to configure a PROFIBUS driver and connect a device type in the
Siemens SIMATIC Process Device Manager (PDM).

a Video

See also the video PROFIBUS parameterization in SIMATIC PDM.

49.1 Prerequisites

= |f you are working on Windows 7 and you have disabled the automatic update service you must
check if Microsoft hotfix KB3033929 is installed.
Open a command line, click [Start], type cmd and in the command window that opens, type
wmic gfe|find "3033929".
The answer contains information about the time, date and Internet address of the installation.

=  The PDMlibraries of the Softing PROFIBUS must have been downloaded from the pnGate
product website and must be installed.

= EDDfiles and libraries of the PA devices must be imported in the PDM Device Integration
Manager.
If not available, download them from the Siemens support website and import them in the DIM.

49.2 Configuring the PROFIBUS driver

See the description Configuring the PROFIBUS driverD¥ in the previous chapter.
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49.3 Connecting the SIMATIC Manager
This Chapter describes how you connect your pnGate PA EX with the SIMATIC Manager:

1. Select Start > All Programs - Siemens Automation - SIMATIC > SIMATIC Manager to create a
new project.

2. Click Options > Select PG/PC Interface.
A new window with a dropdown menu opens.

3. Select from the dropdown menu Interface Parameter Assignment used > Softion PROFIBUS
Interface PROFIBUS.1.

4. Click the [Properties...] button.
A new window opens.

5. Verify that the board number corresponds to the node number in Step 4 of the previous
- 3
section-"™.
This is typically the default node name "Node0".

6. Close both windows with [OK].
You will return to the main window (Component View).

A logical connection has been established between the pnGate PA and the SIMATIC
Manager.

7. Goto View > Process Device Network View.

'—,l SIMATIC Manager - [PDM_sample_new (Component view) -- C:\Program Files (x86)\5i

2B File Edit Insett PLC Options  Window Help

I * Component view Hiter

Process Device Plant View

Process Device Metwork View

8. Right-click on the configuration symbol in the Process Device Network View and select Insert
New Object > networks.

.‘}l SIMATIC Manager - [PDM_sample (Process Device Network View) -- C:\Program Files (xB¢
% File Edit Inset PLC View Options Window Help

0= |27 =] By &5 || < No Fiter >
Ty
Cut Ctrl+X
Copy Ctrl+C
Paste Ctrl+V
Delete Del
Insert Mew Ohbject » networks |
PLC r I

9. Right-click on the network symbol and select Insert New Object > Communication networks.
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£ File Edit Inset PLC View Options Window Help

H < No Fitter =

2 o [e-
2_| =&
= s

=17

Dw|2e| % 2R dall2

% FDM_sample
LB B
5E

----- POM_sam|

Open Object Ctrl+Alt+0

Cut Ctrl+X

Copy Ctrl+C

Paste Ctrl+V

Delete Del

1

Insert Mew Object 3 Communication network

Access Protection 3

SIMATIC PDIM 3

10. Click the [Assign Device Type...] button.
The Assign Device Type window is opened.

11. Select PROFIBUS DP network in the new window.

.
AT e (S

Device Type
- im Networks

(- HART server
+-B@ MODEUS
B“ PROFIBUS DP
- Bm PROFIBUS DF networks

& | PROFIBUS DF network

- PROFINET

(&=}

Description:

Order Number:

Status

12. Click [OK] in both windows.
You are back in the Process Device Network View.

13. Right-click in the left column PROFIBUS DP network - SIMATIC PDM - Start Lifelist.
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@ File Edit Inset PLC View Options Window

Help

Do |[276F| 4 2@ |da|o % 2[x¢

|| < Mo Fitter =

A

= FOM_zample

Open Object
Cut

Copy
Paste

Delete
Insert New Object

Access Protection
SIMATIC PDM

Rename

Object Properties...

Ctrl+Alt+0

Ctrl+X
Ctrl+C
Ctrl+V

Del

F2
Alt+Return

3

3

4

14. Click the Start Scanicon (*) in the top left corner under the menu bar.
This will run a network scan to verify that the PA device can be reached.

Export...
Import...

Load to Device...

Load to PG/PC...

Update Diagnostics...

Start Lifelist

Show change log...

The icon (&) indicates that a device can be reached to read and write process parameters.

LifeList - PROFIBUS DP network

File Edit Device View Options
B = W 2 | Min. address 120

Help
Max, addre

Accessible nodes

Address  Manufacturer

EE- PROFIBUS DP network |

F 125

VEGA Greshaber KiG

15. Close the window in the top right corner (Bs)
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16. Right-click in the PROFIBUS DP network view and select Insert New Object > Object.

.‘-} SIMATIC Manager -"[PDM_sample (Process Device Network View) - é\Plogram Files (x86)\Siemens\Stey
@File Edit Insert PLC View Options Window Help
|Dw |26 4 Ba | ala|[o 2%

] = Mo Fitter » _i

% PDM_sample
B POM_sample_network
B WD
Open Object Ctrl+Alt+0
Cut Ctrl+X
Copy Ctrl+C
Paste Ctrl+V
Delete Del
Insert Mew Object v Object |
Access Protection 3
SIMATIC PDM »
Rename F2
Object Properties... Alt+Return
1

17. Click the [Assign Device Type...] button.
A new window opens.

Insert Object - Assign Device Type @Iﬁ
Device Type
=il VEGA Grieshaber KG -
-] VEGAFLEX 50
Il VEGAFLEX fix

-] VEGAFLEX 80 series Rev.1 DD Rev.2
1l VEGAFLEX 80 series Rev 2 DD Rev 1
VEGAPULS 40/50
'm

... [l VEGAPULS Serie 50
Il VEGAPULS 61 Rev 2 DD Rev 2
-] VEGAPIULS 62 Rev.2 DD Rev.2
Il VEGAPULS 63 Rev 2 DD Rev 2 W
-] VEGAPIULS 65 Rev.2 DD Rev.2
Il VEGAPULS 66 Rev 2 DD Rev 2
-] VEGAPILS 67 Rev.2 DD Rev.2
-] VEGAPULS 68 Rev 2 DD Rev 2 i
Description VEGAPULS40

.

Order Number:  siche unter www vega.com

Status:
Action finished without emors. -

[ Device identification ]

18. Select the device you want to access from the device type list and click [OK].
19. Enterthe PROFIBUS address.

20. Click [OK] to confirm.
The window closes.

21. Right-click in the Process Device Network View on the device you have just selected and select
Object.
This opens the SIMATIC PDMview which shows the parameter values of the selected device.

Version EN-062022-1.00 43



pnGate PAEX - User Guide

vegopuls T T e T

File  Device View Diagnostics Options Help

H&ESUNeRShK:E & ?

= ‘.' Vegapuls Parameter | Value
g VP A EIVEGAPULS 40

,-,? Idertification

-2 Input Class | Echo Lewvel

e[ Cutput =l Identification

| Cenficates and Approvals i

[#-["| Sonsor optimisation (VEGA specific)
TAG |Vegapuls
o RS P

22. Click the Measured Value Display icon ( &) underneath the menu bar to import the parameter

values of the PA device to the Process Device Manger.
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LED status indicators

The pnGate PA EX displays eight device status LEDs and two RJ45 connection status LEDs on the front

side:

Device status LEDs

PWR RUN

O @

ERR  CFG

PN
SF BF

OO O O

SF BF
PA

PWR
RUN
ERR
CFG
SF

BF

The device status LEDs are permanently on or flash in different colors and frequencies as indicated

= powersupply - refer to next section

RJ45 status LEDs

D46

. . 46
= running - refer to next SECtIOI’]D

. 46
= error - refer to next sectlonD

= configuration - displays configuration upload - refer to next section
=  system faults - displays Modbus/PROFIBUS system faults (wrong configuration,

internal error, ...)

= busfaults - displays Modbus/PROFIBUS bus faults

below:

Symbol Color Lighting

® none off

‘ red permanent

. green permanent

8 red flashing (1 Hz)

e red flashing quickly (5 Hz)
8 green flashing (1 Hz)

G green flashing slowly (0.5 Hz)
O green flashing quickly (5 Hz)

The RJ45 status LEDs indicate the following behaviour:

]

Symbol Color Lighting
. green permanent when Ethernet
connection is on
vellow flashing when Ethernet

connection is active
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5.1 Status LEDs (PWR, RUN, ERR and CFG) in stand-alone mode

LEDs Meaning

PWR RUN Start—up phase (approximately 10 seconds)

@
S

ERR CFG
PWR RUN Operating system starts (approximately 2 seconds)

@ O
0 &

ERR CFG

PWR RUN Device is running in factory mode (only firmware update is possible)

@ ¢
® &

ERR CFG

PWR RUN Device is running/operational

@ O
SN

ERR CFG
PWR RUN Software error
. . A software error occurred. Reboot the device. Refer to error description in web
. ® browser (Diagnosis > Logfile > Support Data).
ERR CFG
PWR RUN Permanent hardware fault detection during startup
Afatal error has been detected. Refer to error description in web browser
(Diagnosis - Logfile > Support Data).
ERR CFG
PWR RUN Software error occurred, device has restarted automatically and error is
reported in log file
Delete log file in web browser (Diagnosis > Logfile > Support Data).
ERR CFG
PWR RUN Firmware update is running (in factory mode if blinking red)

ERR CFG
PWR RUN No power on device

® ® Check power supply.

ERR CFG
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5.2 PROFINET device LEDs (PN)

LEDs Meaning
SE BF No connection to controller
Possible causes: PROFINET name is missing on the gateway or the physical

® ' connection to the gateway is interrupted.
SE BF Connection establishment

Q Time period the system needs to establish a connection; devices cannot yet
® communicate with each other.
SF BF Connected to controller
® ‘ All devices are exchanging data.
SE BF Configuration error or diagnosis
c . Read errors from PROFINET engineering system.
SE BF PROFINET signal function active
2, QX
SE BF Error in the PROFINET part of the device

An error such as a software errorl*® or a license error has occurred.

5.3 PROFIBUS master LEDs (PA)

LEDs Meaning
® ‘ All channels offline
SF BF
® ‘ All devices exchange data on all channels
SF BF
® 8 8 At least one used channel is not online
/
SF BF
8 . 8 At least one slave is not in data exchange
/ (BF: green - all channels are online; red: not any channel is online.)
SF BF
‘ ‘ Error in the PROFIBUS part of the device
An error such as a software error(* or a license error has occurred.
SF BF
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6 Declaration of conformity

This device is compliant with EC directive 2014/30/EG, "Electromagnetic Compatibility" (EMC
directive) and meets the following requirements:

= EN 55011 Industrial, scientific and medical (ISM) devices - radio disturbance -
limits and methods of measurement
= EN 55032 Electromagnetic compatibility of multimedia equipment (MME) and
interference
emission

EN 61000-6-4 Electromagnetic compatibility (EMC); Part 6-4: generic standard —
emission for industrial environments

EN 61000-6-2 Electromagnetic compatibility (EMC); Part 6-2: generic standard -
immunity for industrial environments

Note

To fulfill the EMC requirements, the other components of your installation (DC
adapter, Industrial Ethernet devices, etc.) also have to meet the EMC requirements. A
shielded cable must be used. In addition, the cable shield must be grounded properly.

CAUTION
This is a Class A product. In a domestic environment this product may cause radio
interference in which case the user may be required to take adequate measures

CE
The CE marking indicates conformity with the above standards in a Declaration of
Conformity which can be requested from Softing Industrial Automation GmbH.

RoHS

OMPLIANT This product is compliant the Restriction of Hazardous Substances under Directive
2002/95/EC-

FCC

This equipment has been tested and found to comply with the limits for a Class A
digital device, under part 15 of the FCC Rules. These limits are designed to provide
reasonable protection against harmful interference when the equipment is operated in
a commercial environment. This equipment generates, uses, and can radiate radio
frequency energy and, if not installed and used in accordance with the instruction
manual, may cause harmful interference to radio communications.

AERE>E

VCcl

This Class A product conforms to the regulations of Voluntary Control Council for
Interference (VCCI) by Information Technology Equipment.

VEl

WEEE

In compliance with Waste Electrical & Electronic Equipment (WEEE) Directive
2002/96/EC, electrical and electronic equipment must be disposed of separately from
normal waste at the end of its operational lifetime. Packaging material and worn
components shall be disposed of according to the regulations applicable in the country
of installation.
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7 Glossary

DC Direct Current - electric current flowing in only one direction

DIN Deutsches Institut fiir Normung

DTM Device Type Manager

DP Decentralised Peripherals

EDD Electronic Device Description. A file created by the device manufacturer
or aservice provider. Itis shipped together with the device on a data
carrier and / or made available for download from the Internet by the
manufacturer.

EDDL Electronic Device Description Language

ETH Ethernet

Ex Explosion protection

FDT Field Device Tool

GND Ground

GSD General Station Description. A file containing general data about the

configuration of a PROFIBUS field device as provided by the device
manufacturer. The GSD file is required so that a PLC can communicate
with a PROFIBUS field device.

GSDML General Station Description Markup Language. A GSDML file contains
general and device-specific data for communication with and network
configuration of PROFINET I/O devices.

/O Input/Output

IP Internet Protocol

PA Process Automation

PB PROFIBUS

PDM Process Device Manager (sometimes aka Plant Device Manager)
PLC Programmable Logic Controller

pnGate PROFINET gateway

RDL Redundancy Link

T temperature

TIA Totally Integrated Automation
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